
MIC Microscopy Workshop 2022 
ImageJ Computer lab

Please wear a mask, your neighbor may have a medical condition!

35 sqft = 6 ft away from anybody else 

Feel free to ask questions



FIJI SETUP

Windows: copy “fiji-win64.zip” to the desktop, open and extract 
“Fiji.app” to the desktop. Run “ImageJ64.exe”, Help > Update ImageJ

Mac: copy “fiji-macosx.dmg” to the desktop, open it, drag the FIJI 
icon (left) to the desktop. Click on FIJI, Help > Update ImageJ

Help > about ImageJ: v. 1.52a

Copy folder “Images” from fash drives 

Install Image Stabilizer plugin:
Copy “Image_Stabilizer.class” and “Image_Stabilizer_Log_Applier.class” 
from flash drive
Plugins > Install Plugins and navigate to folder 
Restart Fiji
Plugins > Image Stabilizer: “There are no open images”



MIC WORKSHOP, Spring 2022
Vincent Schram, Ph.D.

LIGHT MICROSCOPY 1: TRANSMISSION AND FLUORESCENCE 
Monday May 9, B35 / GG607, 11 am - 1:30 pm

LIGHT MICROSCOPY 2: CONFOCAL, 2P AND LIGHT SHEET 
Tuesday May 10, B35 / GG607, 11 am - 1:30 pm

LIGHT MICROSCOPY 3: SUPER-RESOLUTION IMAGING 
Wednesday May 11, B35 / GG607, 11 am - 1:30 pm

IMAGE ANALYSIS WORKSHOP: IMAGEJ
Thursday May 12, B35 / GG607, 9:30 am - 12:30 pm / 1 pm - 4 pm

CONFOCAL MICROSCOPY HANDS-ON
Friday May 20, B35 / GD922, 9:30 am - 12:30 pm / 1 pm - 4 pm



Digital Image

Digital image:
Two-dimensional array of intensities 
Origin = upper left corner

Pixel depth = number of bits (0-1) in each cell

Grayscale image: 
1-bit (binary)
8-bit (0 – 255),
16-bit (0 - 65,535)
Look-Up Table (LUT): black to _color_ instead of B&W

Color image: Composite of red, green and blue layers 
24-bit = 3 x 8-bits image (R, G, B)

Clipping: “washed-out” appearance (CCD)
➔ re-scale min and max intensity values



Image Dimensionality
Locations

Tile

“Flat”

z

Time

Color 
(Channels)

Spectral 
(λ)

Any combination + images saved sequentially in single file
➔ Formatting information critical...!



Fluorescence image
Fluorescence image: bright signal on black background

⇔ + +

➔ RGB image: red, green and blue color for clean channel separation
➔ Tiff: > 3 non-primary layers (yellow, cyan, purple, pink…) possible

White and black values: use full intensity scale (some exceptions)

Reduce gain Adjust offset Adjust gain / offset Optimal

I=max 
I=0



Transmission image

Dark signal on bright background, no RGB color separation

Color 
Deconvolution 

H&E DAB

Extended depth of field
➔ No easy way to render volume



Image compression

TIF 
no compression 

485 kB

JPG 
90% quality 

62 kB

JPG 
50% quality 

15 kB

➔ Do not use compression!



Image noise

■Noisy image = low signal (camera) 
or high gain (confocal PMT)

■Noise reduced by image averaging 
(last resort…!)



Thresholding

■Bin pixels above / below intensity value(s)
(segmentation)

■Primary method to automatically isolate 
features and create masks (binary images)

■Severely impacted by noise, uneven 
illumination, uneven background



Filtering
■Filter = structuring element

➔ Intensity transformation based on neighbor pixels

0 0 0 1 1 1 -1 -1 -1 1 2 1
0 1 0 1 1 1 -1 6 -1 2 4 2
0 0 0 1 1 1 -1 -1 -1 1 2 1
null median Find edges Blur

■Gaussian filter

x

■Other type of filters: Binary (erode, dilate)
Time-based (frame before / after) 
Frequency-based (Fourrier transform)



Projection

Stack = series of images 
Focal planes ➔ volume 
Time ➔ kinetic

Maximum Intensity Projection (MIP):
Retain highest-intensity pixel for each x,y 
location

3D projection: illusion of volume

Time series ➔ trajectory (MIP)



Channel cross-talk

Crosstalk: signal from one channel spills onto another (up Α)
➔ Sequential instead of simultaneous recording

Dapi Alexa 488 (simultaneous) Alexa 488 (sequential)

100% overlap / colocalization = cross-talk…!

+ =
✓



AI Processing
Self-optimizing convolutional network:



AI applications
Too messy for “hard” (conventional) processing

Denoising, segmentation, feature extraction, deblurring, 
resolution enhancement, etc…

DIC Ground Truth ConvertAI GT Red / AI Green R=0.53

➔ No explicit model / rationale
➔ Training set + computer time
➔ “Image forecast”, validation (required, save your CNN)

➔ Use only when hard processing fails



Bias In Image Processing

User-selected field of views are already heavily biased
➔ Document selection criteria

Not an exact science
➔ Carefully document processing workflow
➔ Rationale for user-adjustable parameters (threshold, radius…)
➔ Optimize each step and overall workflow (wet bench)

User Bias = Qualitative data
➔ Relative comparisons only
➔ User bias not specific to microscopy data
➔ Microscopy results used in combination with other data

➔ Trust your own judgement

➔ Trust your eyes: not visible = unlikely to exist



BEST EFFORT TO RECORD 
HIGH-QUALITY IMAGES…!

YOU CANNOT ANALYZE 
YOUR WAY OUT OF BAD 
IMAGES...! (even w/ A.I.)



FIJI SETUP

Windows: copy “fiji-win64.zip” to the desktop, open and extract 
“Fiji.app” to the desktop. Run “ImageJ64.exe”, Help > Update ImageJ

Mac: copy “fiji-macosx.dmg” to the desktop, open it, drag the FIJI 
icon (left) to the desktop. Click on FIJI, Help > Update ImageJ

Help > about ImageJ: v. 1.52a

Copy folder “Images” from flash drives 

Install Image Stabilizer plugin:
Copy “Image_Stabilizer.class” and “Image_Stabilizer_Log_Applier.class” 
from flash drive
Plugins > Install Plugins and navigate to folder 
Restart Fiji
Plugins > Image Stabilizer: “There are no open images”



FIJI = IMAGEJ

Public-domain image analysis, created by Wayne Rasband at NIH. 

Written in Java ➔ Cross-platform (Windows / Mac / Linux) 

Large number of free plugins, community support

Micro-manager: acquisition version, good driver support

Jack of all trades ➔ convoluted, redundant menus

Free and fast alternative to Photoshop: www.Irfanview.com (Windows)
➔ Cropping, annotations, color adjustment, batch processing, etc…

www.Irfanview.com


Setup & Introduction

Memory and Threads: Edit > Options > Memory & Threads, restart 

Open Fluocell.tif, zoom in & out, pan, pixel location and values

Tool area: right click for options (down arrow = popup menu, broken vs. 
straight line), double-click for more options (line width).

Draw an area, click on it and move / resize. Select an area, Edit > Copy, 
click outside area, Edit > Paste. Click inside ROI and drag. Click outside 
area. Edit > Undo (1 level only), File > Revert.

Draw an area, Image > Crop. Edit > Undo. Draw an area, Image > 
Duplicate. File > Revert.

Open Fluocell color.tif, Image > Color > Split Channels, LUT > Red, 
Green and Blue to each, check each Image > Type = 8 bit (w/ palette), 
Image > Color > Merge Channels, uncheck Create Composite, OK.
File > Close all



Calibration & Overlay
Set scale: Open Ruler.tif, draw reference line between landmarks, 

Analyze > Set scale, enter known distance. Click anywhere, Analyze > Set 
scale, show 2.49 pixels / micron. File> Close.
Open Fluocell.tif, Analyze > Set scale (1 pixel = 0.28 µm), OK, Analyze > 
Tools > Scale bar (destructive)

Text: double-click text icon, select font size, color = red, click on image, 
type text, Don’t click!, Image > Overlay > Add selection (non-destructive, 
Image > Overlay > Show / Hide). Image > Overlay > Flatten, destructive, 
image becomes RGB to accommodate red color. File > Close All.

Calibration bar: Open Fluocell.tif, LUT > Fire, Analyze > Tools > 
Calibration bar (overlay option). File > Close

Manual time stamp: open Live.tif, select color with color picker 
(default=black). Image > Stack > Time stamper, (know) interval = 4 sec., loc. 
200, 10, uncheck ‘00.00’ format, suffix: sec, OK. “\” or wheel. File > Close

B/C: Open Uneven.tif. Image > Adjust > Brightness/Contrast, Auto = 
normalize. Apply to commit (change data!). Close.



Measurements

Plot profile: open Dapi.tif, draw line across particle, Analyze > Plot 
profile (Ctrl-k), List, File > Save as. Click Live, move and redraw line.

Measure: draw region, Analyze > Set Measurements, Area, Mean gray 
value, SD, Min & max, OK. Analyze > Measure (Ctrl-M)

Multi-measure: draw region, Analyze > Tools > ROI manager > Add, draw 
other regions and add them, Measure (ROI man.). Close ROI manager.

Intensity distribution: draw region, Analyze > Histogram, click Live and 
move / resize region. Close histogram.

Object counting: right-click on Point Tool > Multi-point tool. Click on 
multiple objects in image, Ctrl-M = coordinates.

Distances: Analyze > Set Scale 0.28 µm/pix, draw line, Analyze > Tools > 
ROI manager > Add, draw segmented line, add to ROI manager, Measure.



Particle Analyzis

Binary image: open Dapi.tif, Image > Adjust > Threshold, Click Dark 
Background, Make objects red, Apply = make binary (1-bit).
Process > Binary > Make binary equivalent to Apply. File > Revert.

Distribution
Set scale at 0.28 µm/pix, threshold and binarize (Objects may be dark, 
check intensity). Analyze > Set Measurements, click Area + Center of 
mass. Analyze > Analyze particles, show outlines (always!), display 
results + exclude on edge + clear results, OK. Close Measurement, File > 
Revert.

Morphometry:
Set scale at 0.28 um / pix, Image > Duplicate, Image > Adjust > Threshold, 
make objects red, Apply (convert to binary), Analyze > Set Measurements, 
Area + Mean + SD + Center of mass, redirect to Dapi.tif (greyscale).
Click on binary image, Analyze > Analyze particles, set size classifier, OK. 
File > Close.



Filters

Background: Open Uneven.tif. Draw line full diagonal, Ctrl-k. Click on 
Uneven.tif, Process > Subtract background , uncheck light background, 50 
pix rolling ball, OK. Click image, Ctrl-k. Open out-of-plane.tif, repeat.

Noise: open Noisy.tif, Process > Noise > Despeckle, File > Revert, 
Process > Filters > Median. Close.

Stripes: open Banding.tif. Process > FFT > Bandpass Filter, down to 100, 
up to 2 pix, horizontal stripes, all options off.

Binary filters: open Noisy.tif, Image > Adjust > Threshold, Apply. 
Process > Binary > Options, Count = 4
Process > Binary > Erode, Process > Binary > Dilate. Close.
Redo with Process > Filters > Gaussian Blur on greyscale image.



Stacks - z series
Dimensions: Open Root Red.tif, browse in z with slider. Close.

Open Root Dual Color.tif, browse in z and color. Close all.

Import / export: Open Live.tif, File > Save as > Image sequence, start 
and increment number (create new folder!). Close file. File > Import > 
Image sequence, click on open, check Sort names numerically, OK.

➔ Build a stack to batch-process multiple images...!

Maximum Intensity Projection:
Open Root Red.tif. Image > Properties, check / set x, y z at 0.28/0.28/0.39 
µm / pix. Image > Stack > Z-projection, select Max intensity, OK. Close.

3D projection: Click Root Red.tif, Image > Stack > 3D projection 
brightest point, y-axis rotation, 180 w/ 5 deg increment, interpolate, OK 
(Try different conditions). Plugin > 3D viewer for real 3D.

Open Root Red.tif, draw a line, Image > Stack > Reslice (kimograph). 
Delete line from stack (click), Image > Stack > Reslice (resample volume, 
orthogonal sections). Close all.



Stacks - Time series

Intensity: open Live.tif, draw region, Analyze > Set Measurements, 
Mean gray value + SD + Stack position, Analyze > Measure (Ctrl-M) = 1 
plane only. Image > Stacks > Plot z-axis profile.

Multi-measure: Analyze > Tools > ROI manager > Add, draw and add 
other regions, More > Multi-measure, select all slices + one row per slice. 
Close.

Temporal color code: open Track.tif. Image > Hyperstack > Temporal 
color code, Lut = Fire, create scalebar. Can be used to depth-code z-
stacks. File > Close All.

Enhance contrast: Neurite.tif, Process > Enhance contrast, uncheck all 
options except Process all slices. Can be used with flat images

Image stabilizer: on first slice of Neurite.tif, Plugins > Image stabilizer, 
translation, output to new stack. File > Close All.



EXERCISES

Exercise 1: Motion Tracking

Open Track.tif. Establish position of bead versus frame number.
Hint: threshold

Solution:

Image > Adjust > Threshold, Dark background, Apply. 
Analyze > Set Measurements, Center of Mass. 
Analyze > Analyze Particles

➔ If problem thresholding: substract background



Exercise 2: Colocalization
Open Mito Division.tif. Analyze colocalization between green and red 

channels
Hint: separate colors, smooth, Analyze > Coloc. > Coloc. Threshold

Solution:
Image > Adjust > Brightness / Contrast, Auto (both channels) 
Excessive noise: Process > Filter > Gaussian Blur, 1.5, Preview, OK 
Image > Colors > Split Channels
Analyze > Colocalization > Colocalization Threshold
Assign channels 1 and 2, no ROI, Red/Green combo, check Show 

Colocalization Map, Scatter Plot and Set Options. Click OK
Options: Check Show Linear Reg. Sol., Show Thresholds and Pearson’s 

Above Threshold, % Image Volume Colocalized. Click OK

Control:
Green and red images: Image > Type > 8 bit, Image > Color > Merge 
Coloc. Pixel Map: Image > Type > 8 bit, LUT > Yellow, Adjust B/C
Compare both images

➔ 100% yellow overlay = Crosstalk, not colocalization



Exercise 3: Dynamic Intensity meas.
Open Live.tif. Measure intensity of cell in lower left quadrant 

Hint: crop image and isolate cell based on size. Morphometry.

Solution:
Image > Stacks > Z Project…, Max Intensity 
Draw ROI around cell
Click on Live.tif, Edit > Selection > Restore Selection. 
Image > Duplicate, check Duplicate Stack.
Process > Filters > Gaussian blur, sigma=1, OK, all slices 
Click on Live-1.tif, Image > Duplicate
Image > Adjust > Threshold, Apply
Analyze > Set measurements, check Area, Mean grey value, SD and 
Stack position. Redirect to Live-1.tif (greyscale), OK.
Click on Live-2.tif (binary)
Analyze > Analyze Particles, size: 150 µm2 -inf, Show outlines, Check 
Display results, Include holes. Uncheck Exclude on edge.
Process all images, OK.

➔ Show Outlines = critical consistency check



Exercise 4: RNAscope
Open RNAscope.czi, estimate number of dots per cell 

Hint: Process > Binary > Voronoi for cell outlines

Solution:
Image > Color > Split Channels, Image > Adjust > B/C, Auto

1) Dapi image: Image > Duplicate
Process > Filters > Mean, radius=10 
Image > Type > 8 bit

Image > adjust > Auto local threshold, Niblak, r=15 
Image > adjust > Threshold, 1-255, Apply
Analyze > Analyze Particles, 40-inf, show masks, exclude on edges 
Process > Binary > Erode, then Dilate, then Watershed.
Image > Duplicate ➔ (1). On dup., Process > Binary > Voronoi 
Image > Adjust > Threshold, 1-255 Apply ➔ (2)
Process > Image Calculator, Add (1) and (2)
Image > Adjust > B/C, lower Brightness, Set. Image > Type > RGB

2) RNAscope image: Process > Subtract Background, 10
LUT (Fn key) > Fire, B/C Auto. Image type > RGB, Add to above

➔ Possible to segment challenging images without AI



Exercise 5: Batch processing / Scripting
Open BRDU image folder, measure nucleus size on each image 

Scale = 0.8 um / pixel

Solution:
Plugins > Macro > Record 
Open BRDU1.tif
Analyze > Set scale, 1 pixel = 0.8 um, OK
Image > Adjust > Threshold, uncheck Black background, Apply.
(clear additional threshold entries from log)
Process > Binary > Erode, then Process > Binary > Dilate 
Analyze > Set measurement, Area.
Analyze > Analyze particle, 50-inf., Display Results, Exclude on edge,

uncheck Clear Results (do not Show Outlines, requires variables…!)
Recorder window: copy all lines except first
(Do not close a single window until that point!)
Process > Batch > Macro, select input folder, paste macro in window 
Close all windows, Process.

➔ Batch processing dangerous, check consistent image quality…!



FIJI TAKE-HOME MESSAGE
Pros:

Powerful and extensible with plugins, scriptable 
Community support (http://rsbweb.nih.gov/ij/) 
FREE

Cons:
Menus not very intuitive 
Plugins not always stable 
Not scalable to large images

➔Hard processing / AI cannot turn crap into gold:
CRAP IN = CRAP OUT

➔ No “undisclosed” image manipulation

➔ Do not batch-process unless consistent image quality

http://rsbweb.nih.gov/ij/)
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